Skip to main content
Call us
Phone numbers and hours
Help Center

Explore our online help resources

Help

GoDaddy Help

Export or backup my contacts, calendar, and email

Create an Outlook backup file to save and export email messages, contacts, and calendar info. You can then import your backup to a new email plan, email service, or a new version of Outlook. The export won’t include meta-data such as folder properties (views, permissions, and AutoArchive settings), message rules, and blocked sender lists.

Note: GoDaddy doesn't support manual backups or imports of Outlook Data Files (.pst and .ost).

Select your version of Outlook to see its steps. Not sure what version you have? Here's an article from Microsoft on finding your version of Outlook.

Windows Mac Web

Outlook 2013, 2016, or newer

Outlook 2010

Outlook 2007

Outlook 2016 or newer

Outlook 2011

Outlook on the web (contacts only)

Outlook for Windows

Outlook 2013, 2016, or newer (Windows)

  1. Open Outlook.
  2. In the upper-left corner, select File.
  3. Select Open & Export > Import/Export.
  4. Select Export to a file > Next.
  5. Select Outlook Data File (.pst) > Next.
  6. To export the entire mailbox, select the name of the email account and continue to the next step. Or, to only export your Calendar or Contacts folder, select the folder you want to export. (You can export one type at a time, so you'll need to repeat these steps to export both Contacts and Calendars individually.)
  7. Make sure that the Include subfolders checkbox is selected, and then select Next.
  8. Select Browse to choose where to save the Outlook Data File (.pst). Enter a file name and select OK to continue.
  9. If you're exporting to an existing Outlook Data File (.pst), under Options, specify what to do when exporting items that already exist in the file.
  10. Select Finish.
  11. The export begins immediately unless a new Outlook Data File (.pst) is created or the export is to an existing .pst file that's password protected.
    • If you're creating an Outlook Data File (.pst), an optional password can help protect the file. When the Create Outlook Data File dialog box appears, enter the password in Password and Verify Password, and then select OK. In the Outlook Data File Password dialog box, enter the password and select OK.
    • If you're exporting to an existing Outlook Data File (.pst) that's password protected, in the Outlook Data File Password dialog box, enter the password and select OK.

Back to top

Outlook 2010 (Windows)

Microsoft ended support for Office 2010 on October 13, 2020 and these instructions are for reference only. Learn more from Microsoft.

  1. Open Outlook.
  2. At the top of the ribbon, choose File and select Options.
  3. In the Outlook Options box, choose Advanced.
  4. Under the Export section, choose Export.
  5. Select Export to a file and Next.
  6. Select Outlook Data File (.pst) and Next.
  7. Select the name of the email account to export. Only information for one account can be exported at a time.
  8. Select the Include subfolders checkbox to export your Calendar, Contacts, and Inbox. Select Next.
  9. Select Browse to choose where you want to save the Outlook Data File (.pst) and to enter a file name. Select OK to continue.(If you previously exported a file, make sure you change the file name instead of using the existing file name.)
  10. If you're exporting to an existing Outlook Data File (.pst), under Options, choose what to do when exporting items that already exist in the file.
  11. Select Finish.
  12. The export begins immediately unless a new Outlook Data File (.pst) is created or the export is to an existing .pst file that's password protected.
    • If you're creating a new Outlook Data File (.pst), an optional password can help protect the file. When the Create Outlook Data File dialog box appears, enter the password in Password and Verify Password, and then select OK. In the Outlook Data File Password dialog box, enter the password and select OK.
    • If you're exporting to an existing Outlook Data File (.pst) that's password protected, in the Outlook Data File Password dialog box, enter the password and select OK.

Back to top

Outlook 2007 (Windows)

Microsoft ended support for Office 2007 on October 10, 2017 and these instructions are for reference only. Learn more from Microsoft.

  1. Open Outlook.
  2. At the top of the ribbon, choose File.
  3. Select Import and Export.
  4. Select Export to a file and Next.
  5. Select Personal File Folder (.pst) and Next.
  6. Select the name of the email account to export. Only information for one account can be exported at a time.
  7. Select the Include subfolders checkbox to export your Calendar, Contacts, and Inbox. Select Next.
  8. Select Browse to choose where you want to save the Outlook Data File (.pst) and to enter a file name. Select OK to continue. (If you previously exported a file, make sure you change the file name instead of using the existing file name.)
  9. If you're exporting to an existing Outlook Data File (.pst), under Options, choose what to do when exporting items that already exist in the file.
  10. Select Finish.
  11. The export begins immediately unless a new Outlook Data File (.pst) is created or the export is to an existing .pst file that's password protected.
    • If you want to password protect your .pst file, enter the password in Password and Verify Password, and then select OK. In the Outlook Data File Password dialog box, enter the password, and then click OK.
    • If you are exporting to an existing Personal File Folder (.pst) that is password protected, in the Outlook Data File Password dialog box, enter the password and select OK.
  12. Select OK if you don't want to password protect your file.

Back to top

Outlook for Mac

Outlook 2016 or newer (Mac)

  1. Open Outlook.
  2. If you're in the new version of Outlook, turn off the New Outlook switch. Otherwise, continue to the next step.
    New Outlook toggle
  3. On the Tools tab, select Export. (If you don't see Export, look for it on the Outlook File menu.)
  4. In the Export to Archive File (.olm) box, select the checkboxes next to the items you want to export (select all of them to export your entire mailbox), and then select Continue.
  5. In Save As, under Favorites, select the Downloads folder and Save.
  6. You'll be notified once your data is exported. Select Finish.

Back to top

Outlook 2011 (Mac)

Microsoft ended support for Office 2011 on October 10, 2017 and these instructions are for reference only. Learn more from Microsoft.

In Outlook 2011, you have the following export options:

  • Export to an Outlook for Mac Data File
  • Export contacts in a tab-delimited text file
  • Export individual items
Export to an Outlook for Mac Data File

When you export to an Outlook for Mac Data File, you can choose to filter information by category or by item type. During the export process, you can choose to keep the exported items in Outlook, or to delete them after they are exported.

Microsoft Exchange and directory services accounts don't export contacts from the directory or items stored in public folders.

  1. On the File menu, select Export > Outlook for Mac Data File.
  2. Choose an option to filter by category or item type. (To export all items in Outlook, select Items of the following types, and then select all the checkboxes.)
  3. Select the right arrow to continue, and then follow the instructions. The Outlook for Mac Data File saves with the .olm extension.
Export contacts in a tab-delimited text file

Export contacts and related contact info directly as a tab-delimited text file. You can open this file using other mail, spreadsheet, and database applications. Encryption certificates aren't exported.

  1. On the File menu, select Export.
  2. In the Export Assistant, select Contacts to a list, and then follow the instructions. Tab-delimited files are saved with a .txt extension.
Export individual items

You can also export single items as individual files, either to have as a backup or to use in other applications.

  1. In the item list, select the item that you want to export. (To select multiple items, hold down the Command key as you click the items.)
    Item File type
    Email messages .eml
    Contacts .vcf (vCard)
    Calendar events and tasks .ics
    Notes .html
  2. Drag the selection to the desktop or a folder in the Finder.

Back to top

Outlook on the web

Contacts in Outlook on the web

  1. Sign in to Outlook on the web. Use your Microsoft 365 email address and password (your GoDaddy username and password won't work here).
  2. In the lower left corner of the page, select People People.
  3. In the upper-right corner, select Manage > Export contacts.
  4. Choose if you want to export all contacts or only contacts from a specific folder, and then select Export.

Your contacts will save as a .csv file, which you can import to other email apps (like Gmail) or other versions of Outlook.

Back to top

Related step

More info